Zendesk outage - delay in support response
Incident Report for LeadDyno
Resolved
Zendesk's outage has been addressed and we will be responding to LeadDyno support requests as promptly as possible.
Posted Feb 26, 2024 - 12:58 PST
Investigating
We want to inform you that Zendesk, the support platform utilized by LeadDyno, is currently experiencing a known outage. You can find more details about this incident here: Zendesk Service Incident - February 26th, 2024.

Due to this outage, there might be a noticeable increase in response time for support inquiries. Rest assured, our team is committed to addressing your concerns as swiftly as possible once the Zendesk outage is resolved.

Thank you for your understanding and patience.
Posted Feb 26, 2024 - 10:56 PST